Monday, October 23, 2006

Failed to open BAM Excel workbook file: Old format or invalid type library

While trying to deploy a BAM workbook I created with Excel 2002, I received the following error message:

Since I was using an older version of Excel (2002) I thought that installing the 2003-version would fix my problem. Unfortunately it did not...

After some Googleing I found the blog from Don Glover, a Programming Writer for the BAM feature of BizTalk Server. He states that localization was the problem:

"BAM is made up of a number of separate components, SQL, web services, custom tools, and more. In order for each of the components to operate together effectively, they must all be set to the same locale/culture. In addition, your system and user locale/culture should match those set for BAM."

In my case it was enough to change my 'Regional options' from Dutch to English (US).

After firing the deployment command again, all went well.

Thanks Don!